Interne Issues
Incident Report for Fabricut, Inc
Resolved
This incident has been resolved.
Posted Mar 31, 2020 - 07:39 CDT
Identified
We are currently experiencing intermittent internet issues at the corporate office. This will have an effect on Email, TMS and our corporate websites. A tech from Verizon will be onsite today to resolve the issue.
Posted Mar 30, 2020 - 07:05 CDT
This incident affected: Residential Website, Contract Website, Email, and TMS.