Site Performance & Data Issues
Incident Report for Fabricut, Inc
Resolved
The incident has been resolved. Performance is back to normal levels and product data is no current.
Thank you for your patience.
Posted Jun 01, 2023 - 11:49 CDT
Update
We are continuing to work on a fix for this issue.
Posted Jun 01, 2023 - 08:24 CDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 01, 2023 - 08:23 CDT
Update
We are continuing to investigate this issue.
Posted May 31, 2023 - 11:36 CDT
Investigating
Fabricut.com, FabricutContract.com, and Clarencehouse.com are experiencing issues relating to performance and product data issues.
We are investigating the cause and will keep you updated.
Posted May 31, 2023 - 11:36 CDT
This incident affected: Residential Website, Contract Website, API, and TMS.