System Maintenance
Incident Report for Fabricut, Inc
Resolved
System maintenance is complete. All systems are operational.
Posted Jun 19, 2021 - 12:57 CDT
Identified
AS400 System Maintenance continues
Posted Jun 19, 2021 - 12:13 CDT
Investigating
System Maintenance is currently underway
Posted Jun 19, 2021 - 10:24 CDT
This incident affected: Residential Website, Contract Website, Finished Products API, API, TMS, and Download Center.