Website Performance issues
Incident Report for Fabricut, Inc
Resolved
This incident has been resolved.
Posted Oct 24, 2020 - 19:47 CDT
Identified
Performance may continue to suffer but an update has been done to improve performance. The alert remains in effect until further notice.
Posted Oct 23, 2020 - 18:33 CDT
Update
We are continuing to investigate this issue.
Posted Oct 23, 2020 - 18:31 CDT
Investigating
We are currently experiencing website issues due to utility work being performed at the main building at Fabricut. As soon as they work is completed Fabricut.com and all brand sites will return to normal working order.
Posted Oct 23, 2020 - 18:20 CDT
This incident affected: Residential Website, Contract Website, TMS, and Download Center.