Issues with searching fabrics
Incident Report for Fabricut, Inc
Resolved
The search issue has been resolved.
Posted Feb 21, 2018 - 08:48 CST
Investigating
We are having an issue with searching for Fabrics on the websites. The web team is looking into the issue. Once we have more information this page will be updated.
Posted Feb 21, 2018 - 08:09 CST