Issue searching products
Incident Report for Fabricut, Inc
Resolved
The search issue affecting some customers while logged in has been resolved.
Posted Mar 23, 2018 - 10:33 CDT
Investigating
Some users have reported problems searching for products. We are working to resolve the problem as quickly as possible.
Posted Mar 23, 2018 - 09:14 CDT