Web Site performance Issue
Incident Report for Fabricut, Inc
Resolved
The performance issue has been resolved.
Posted Oct 30, 2018 - 08:36 CDT
Update
We are continuing to investigate this issue.
Posted Oct 30, 2018 - 08:36 CDT
Investigating
We are experiencing performance issues. The IT team is working to resolve the issue as quickly as possible.
Posted Oct 29, 2018 - 16:49 CDT
This incident affected: Residential Website, Web Login, and Product Search.