Contract Site Error
Incident Report for Fabricut, Inc
Resolved
The site issue has been corrected. Please contact our Helpdesk if any other issues are observed.
Posted Mar 28, 2019 - 15:04 CDT
Monitoring
We've identified the issue and are working on a correction.
Posted Mar 28, 2019 - 14:58 CDT
Identified
We are currently looking at an outage on the Contract website.
Posted Mar 28, 2019 - 14:52 CDT
This incident affected: Contract Website.