System Outage
Incident Report for Fabricut, Inc
Resolved
This incident has been resolved.
Posted Aug 05, 2021 - 08:11 CDT
Monitoring
Most major functions have been returned to service. We will continue to monitor for issues.
Posted Jul 25, 2021 - 17:26 CDT
Update
Access to email has been restored.
Posted Jul 24, 2021 - 20:50 CDT
Update
We are continuing our recovery efforts. Thank you for your patience.
Posted Jul 24, 2021 - 10:54 CDT
Investigating
We are currently experiencing a major outage on all of our computer systems. IT is currently working on the issue. We send updates regularly.
Posted Jul 23, 2021 - 08:34 CDT
This incident affected: Residential Website, Contract Website, Finished Products API, API, Email, Blog, TMS, AWS CloudFront, Fax / Order Confirmation - FastFax, and Download Center.