Tax calculation software causing issues.
Incident Report for Fabricut, Inc
Resolved
This incident has been resolved.
Posted Apr 25, 2019 - 14:05 CDT
Update
We are continuing to investigate this issue.
Posted Apr 25, 2019 - 12:52 CDT
Update
The Issue has been resolved!
Posted Apr 25, 2019 - 12:52 CDT
Investigating
We are currently experience degraded performance with our Tax calculation service. This could be causing issues with submitting orders to our system.
Posted Apr 25, 2019 - 11:02 CDT
This incident affected: Residential Website.